开始使用CodeMix

CodeMix是一个Eclipse插件,让你访问一个广泛的技术从VS代码和插件扩展了代码OSS。如果你是一个有经验的Eclipse开发人员,CodeMix有几个新的UI元素和可用性模型需要注意的。如果你有经验开发与VS代码,你会发现熟悉这些特性;然而,你将访问他们在CodeMix不同。

CodeMix插件兼容基于eclipse的ide和等工具MyEclipse,春天工具套件和JBoss工具,您可以继续工作环境中你是习惯了。

工作台基础知识

本节讨论一些CodeMix基本面,处理项目和代码时派上用场。

首选项

选择首选项重要的键绑定,支持编辑和验证器,选择Window > preferences Mac(或Eclipse > preferences),然后扩大CodeMix和选择适当的节点。可以直接从CodeMix许多设置。其他设置将包括一个链接在json文件中直接编辑该值。

在扩展,您可以添加语言,调试器和工具CodeMix安装,支持你的开发工作流程。这些设置页封面提供的大多数设置安装扩展。在格式化程序,你会发现格式相关的设置。您可以使用过滤器顶部的首选项对话框中快速找到设置。


CodeMix偏好

VS代码和扩展特定的设置可以在工作区级别或项目级别。如果首选项设置在多个地点,项目设置优先级最高,其次是工作空间设置。

  • 工作空间设置从偏好,选择CodeMix,然后选择适当的节点的设置。工作区设置特定于您的Eclipse工作区中。
  • 项目设置右击你的顶级项目文件夹,选择Properties > CodeMix,然后选择适当的节点的设置。项目设置存储在项目和保留在工作区,系统和用户。

快速打开和命令面板

有效地使用这些功能利用CodeMix的全部潜力,大大提高您的生产力。每个键盘快捷键列(Windows / Mac)。

快速打开(Ctrl + P/Cmd + P)

很快您的工作区中打开的文件。


快速打开

开放的类型(Ctrl + Shift + T/Cmd + Shift + T)

跳转到符号在文件,跨越语言。

打开本地符号(Ctrl + O/Cmd + O)

在当前导航文件,使用过滤器快速找到一个元素。


打开本地符号

命令面板(Ctrl + Shift + P/Cmd + Shift + P)

使用命令从运行npm构建面板,启动调试会话。用它来当前文档格式,或集体应用快速修复;你甚至可以用它来重构代码。命令面板包括Eclipse命令开始输入你需要找一个命令的工作。


命令面板

打开命令面板后,你可以输入#,@>进入类型,分别本地符号或命令模式。

这些键绑定可以开启或关闭Preferences > CodeMix >其他>绑定页面,或定制的Preferences页面>一般>键,类型快速打开过滤器中找到它们。

扩展

扩展添加一系列的功能CodeMix安装支持新的语言和框架,生产力增强编码时,先进的验证和调试功能。

CodeMix自动安装适当的扩展包当你创建一个CodeMix项目,以及明智地建议他们基于你正在编辑的文件。


Python包的建议

手动安装扩展,去帮助> CodeMix扩展。


扩展管理器

有关更多信息,请参见扩展在CodeMix

终端

使用多个终端命令来打开一个CodeMix终端在Eclipse中。您还可以创建一个新的终端的终端视图,在对话框中,选择CodeMix终端。


终端的命令

您可以使用终端:选择默认的Shell命令来改变默认创建的外壳。它包括操作系统特定的选项,例如,像Windows PowerShell 10。

调试

右键单击您的项目打开上下文菜单,并选择Debug As > CodeMix发射(或角的Web应用程序)。如果你的项目不已经有一个launch.json文件,创建一个你可以选择发布类型。可用的启动类型取决于安装的扩展。


调试与launch.json

一旦你创建启动,单击启动图标launch.json编辑器的统治者,或者去调试配置对话框,你可以启动调试会话。CodeMix具体发射将分组CodeMix节点下。


访问调试配置


从调试启动配置

有关更多信息,请参见在CodeMix调试

状态栏

状态栏显示的状态CodeMix连接引擎,和其他相关的细节您正在编辑的文件。例如,显示打印稿打印稿文件的版本,可以改变,而其他项目表明剥绒机是否活跃。


状态栏的通知

如果连接到CodeMix引擎休息,这个图标显示在状态栏,没有CodeMix功能工作。这应该不会发生,但如果是这样,重新启动您的IDE。如果断开连接的状态持续下去,或者如果你经常进入这个状态,请联系支持

常绿的更新

当一个新版本的CodeMix可用,CodeMix自动更新。迫使一个更新,按Ctrl / Cmd + Shift + P和更新CodeMix类型。


迫使一个更新

如果下载更新,一个图标在状态栏显示:。应用更新下次启动Eclipse。

创建一个新项目

创建一个新项目,去File > new >其他> CodeMix和选择任何项目的向导,从一个新的角度反应,Python,等项目。


新项目向导

项目创建过程自动下载相应的扩展包,以确保你有你需要的所有开发支持技术。

注意:根据您的连接速度,可能需要一段时间来下载所有必需的扩展,你可以观看状态区域监控安装进度。当安装完成时,您可能会被要求重新启动CodeMix引擎(不是IDE)扩展的启用。

的项目有READFIRST.md文件包括一些基本步骤你需要运行,构建项目,虽然README.md股票项目本身的更多细节。


READFIRST.md

注意在项目元数据

不像典型的Eclipse项目,CodeMix特征函数在任何文件夹中相应的源文件。在Eclipse-speak,您不需要启用性质,建筑商或智能感知方面,先进的导航或验证开始工作。这是一种释放一旦你习惯的想法。大多数项目与常规布局是可用的。

导入现有的项目

从文件夹或选择File > Import >项目档案,选择项目并将其导入CodeMix。大多数项目是可用的。

CodeMix编辑

CodeMix自动将自身与支持的文件类型,使相应的CodeMix编辑这些文件类型的默认编辑器。明确与CodeMix编辑器中打开一个文件,在文件上单击右键并选择打开> <文件类型>::CodeMix。


打开一个CodeMix编辑器


首选编辑器偏好

注意:你第一次打开工作区与CodeMix,如果打开的编辑器,工作区从这些文件中打开老,non-CodeMix编辑。关闭并重新打开这些文件在CodeMix编辑器中打开它。

编辑代码

不像典型的Eclipse编辑器,大多数CodeMix编辑器显示你内容帮助建议类型,而不必等待一段时间或其他特殊字符。您可以显式地调用内容帮助按下Ctrl + Space,虽然大多数时候这不会是必要的。


智能感知在vue文件

代码折叠格式化在编辑器中,有许多的功能,提高工作效率。其他受欢迎的包括:

  • 视图/去定义鼠标悬停在一个变量的定义,然后按Ctrl(CmdMac)的声明,这是特别有用的方法和函数。你可以点击当紧迫的Ctrl(Cmd在Mac)跳转到相应的代码。
  • 移动线新闻Alt +上/下快速线向上或向下移动。
  • 注释行新闻Ctrl + /切换一个注释行。

扩展通常可以改善一些基本typing-good的例子是自动关闭标签和自动重命名标签扩展。使用标记,如HTML或XML时,自动关闭标签会自动插入一个结束标记当你输入一个新标签,和汽车重命名标签自动重命名匹配关闭或打开标签当你编辑其中之一。

有关更多信息,请参见智能感知在CodeMix,编辑CodeMix,导航代码

建立和验证

CodeMix支持两种验证模式:in-editor验证影响任何文件在编辑器中打开,和项目级别验证用于所有其他文件在您的项目中。

项目级别的验证可以使用通用的内置的验证技术,或者被配置为使用外部的任务,通常用于构建应用程序和服务。在CodeMix构建管道支持,验证和建立经验是无缝的。

进一步的细节,请参阅在CodeMix建立管道和验证任务与tasks.json CodeMix

有用的资源

我们理解的挑战,实现新技术和引入新的软件。我们CodeMix开发团队致力于与您合作确保你从CodeMix得到最大的收获。

新CodeMix 3网络学习。交互式教程引导您通过各种技术和技巧,让你成为一个更高效的编码。指的是CodeMix网络学习指南有关使用此功能。此外,我们还提供免费支持论坛和深入学习中心帮助你获得最CodeMix。你可以访问这些帮助> CodeMix菜单。

高级:项目与CodeMix登记

CodeMix工作在一个给定的项目,该项目必须先注册CodeMix引擎。为了节省资源,将不必要的消费项目不工作,CodeMix将智能注册项目只在需要时。这还有额外的好处,减少引擎启动时间,和结果以最优的整体开发经验。

警告:如果你还没有与一个项目在当前会话,它可能不是注册CodeMix引擎。在这种情况下,从项目将缺席workspace-wide象征符号列表(可以用Ctrl / Cmd + P + @)。类似地,如果您正在处理另一个项目引用符号在这个项目中,这些符号将不会在内容帮助的建议。这通常是一个问题只有当你正在与一些相互依赖的项目。

在这种情况下,您可以与项目交互引擎注册它,或者你可以力与发动机项目的注册,通过检查,“总是在CodeMix启动注册项目”,在项目属性复选框> CodeMix >其他页面。

Baidu
map